首页 新闻 搜索 专区 学院

vs2017创建asp.net core web项目报错

0
悬赏园豆:50 [已解决问题] 解决于 2017-03-26 22:01


这是什么情况,刚安装完,创建个asp.net core项目。

Dukezhou的主页 Dukezhou | 初学一级 | 园豆:157
提问于:2017-03-25 22:20
< >
分享
最佳答案
0

用 dotnet restore 执行一下!

收获园豆:50
Catcher8 | 菜鸟二级 |园豆:364 | 2017-03-25 22:50

恩,这样是可以。不过现在没建一个新项目都会这样, 不知道什么原因。用vs2015没出现过这种情况。

Dukezhou | 园豆:157 (初学一级) | 2017-03-26 09:36

@Catcher8已经重新安装vs2017两次了

Dukezhou | 园豆:157 (初学一级) | 2017-03-26 09:38
其他回答(3)
0

重新还原下

Jeffcky | 园豆:2563 (老鸟四级) | 2017-03-25 22:25

刚创建会有一个还原包的过程,过了一会还是这样?

支持(0) 反对(0) Jeffcky | 园豆:2563 (老鸟四级) | 2017-03-25 22:26

@Jeffcky: 是的,vs2015过一会就好了,vs2017就一直这样,奇怪,难道是我电脑的问题。win7,32位

支持(0) 反对(0) Dukezhou | 园豆:157 (初学一级) | 2017-03-25 22:33

@涛MR: 利用下楼的restore下,再不行重启下vs

支持(0) 反对(0) Jeffcky | 园豆:2563 (老鸟四级) | 2017-03-25 23:17
0

Package Manage Console 中,用 dotnet --info 查看一下 SDK 版本是否匹配!

BUTTERAPPLE | 园豆:2950 (老鸟四级) | 2017-03-25 23:38

创建的默认项目版本是1.1,查出来是1.0,SDK匹配吗?要怎么改呢?

支持(0) 反对(0) Dukezhou | 园豆:157 (初学一级) | 2017-03-26 00:32

@涛MR: 去官网下载最新sdk

支持(0) 反对(0) BUTTERAPPLE | 园豆:2950 (老鸟四级) | 2017-03-26 08:48
0

重新安装ASP.NET ,在IIS里面更新一下,然后重新添加引用看看

男人要爽 | 园豆:15 (初学一级) | 2017-03-26 09:49
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册