首页 新闻 搜索 专区 学院

web api 基于mvc 构建一个ioc 用autofac 写完了之后报错

0
悬赏园豆:5 [待解决问题]

什么情况 autofac4.0的版本 webapi5.0

凤城沙子的主页 凤城沙子 | 初学一级 | 园豆:115
提问于:2017-03-28 11:01
< >
分享
所有回答(3)
0

bin目录下有这个dll吗

吴瑞祥 | 园豆:29187 (高人七级) | 2017-03-28 11:23

你的qq给我 我把代码给你看看

支持(0) 反对(0) 凤城沙子 | 园豆:115 (初学一级) | 2017-03-28 11:24

@itwwg: 这个和代码没关系.没啥好看的.

我都说了.你bin下有这个dll吗.

支持(0) 反对(0) 吴瑞祥 | 园豆:29187 (高人七级) | 2017-03-28 11:26

1838507665  你给我发源码看一下@吴瑞祥: 

支持(0) 反对(0) 凤城沙子 | 园豆:115 (初学一级) | 2017-03-28 13:06
0

NuGet 重新安装 Microsoft.AspNet.WebApi 试试

dudu | 园豆:37175 (高人七级) | 2017-03-28 11:32

不行呀

支持(0) 反对(0) 凤城沙子 | 园豆:115 (初学一级) | 2017-03-28 13:07
0

建议把MVC ,webapi版本都降低到5.2.0.0,我用的Autofac.Mvc5 3.3,Autofac  3.5 ,Autofac.WebApi2 4.0,经过测试可用。在nuget上Autofac.WebApi2目测最高只支持webapi 5.2版本。

ldybyz | 园豆:138 (初学一级) | 2017-03-28 11:52

我看看源码

支持(0) 反对(0) 凤城沙子 | 园豆:115 (初学一级) | 2017-03-28 13:07

@itwwg: http://docs.autofac.org/en/latest/integration/webapi.html 官网有例子

支持(0) 反对(0) ldybyz | 园豆:138 (初学一级) | 2017-03-28 14:04
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册