首页新闻找找看学习计划

IE8兼容性问题,jquery版本问题

0
悬赏园豆:10 [已关闭问题] 关闭于 2017-05-05 10:51

在吗?我遇到了一个问题,就是我用localstorage跨页面传值,然后读取子页面是已经读取到了数据,但页面老是提示脚本错误,不知道怎么回事?

jquey版本是<script type="text/javascript" src="js/jquery-1.8.3.min.js"></script>

这是在IE8测试的,

火狐谷歌提示

如果把jquery改成<script type="text/javascript" src="js/jquery-3.1.1.min.js"></script>

火狐谷歌都没有问题,但IE8提示

网址www.ribbonfairs.com,  littlePaging.html页中存在的问题,请各位路过的大神帮帮忙

问题补充:

路过的各位大神可以去我做的网站在IE8看看,到现在我还没有想出来解决的办法,不知道怎么回事?大神们帮帮忙

小短腿奔跑吧的主页 小短腿奔跑吧 | 初学一级 | 园豆:136
提问于:2017-04-28 16:13
< >
分享
所有回答(3)
0

localstorage在ie低版本有兼容问题 可以考虑换另外一种存储

Artikel | 园豆:387 (菜鸟二级) | 2017-04-28 16:35

那哪种存储好呢?

支持(0) 反对(0) 小短腿奔跑吧 | 园豆:136 (初学一级) | 2017-04-28 16:39
0

官方的说法是 支持IE8+的,具体的没试过。

IE8 不支持 jquery 3.1.1的一些方法;

具体传值可以放cookie ,或者直接用url带参数传值都行;

DNLi | 园豆:343 (菜鸟二级) | 2017-04-28 16:52

因为值太多,url只能传几个,cookie也是,所以才选择的localstorage的,IE8是可以传值的,但jquery版本不知道怎么回事,1.8.3在IE8也提示脚本错误,但localstorage是可以显示的,你可以看看我的网站,在IE8里试一下

支持(0) 反对(0) 小短腿奔跑吧 | 园豆:136 (初学一级) | 2017-04-28 16:57
0

Date 提示不是一个构造器,然后我把代码中的var Date改为,var date就可以使用了,嘿嘿,原来IE这么细小的问题都能导致很大的错误,我之前还以为jquery3.1.1在IE8中不兼容呢

小短腿奔跑吧 | 园豆:136 (初学一级) | 2017-05-03 09:22

这个是正确的,IE8是可以本地存储的,IE6.7不可以

支持(0) 反对(0) 小短腿奔跑吧 | 园豆:136 (初学一级) | 2017-05-05 10:53
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册