首页新闻找找看学习计划

关于vue + ES6 在IE里面的渲染问题

0
悬赏园豆:5 [已关闭问题] 关闭于 2017-05-15 16:18

按照 Vue官方手脚架搭建  发现编译后无法识别新增的一些ES6方法
导致在IE浏览器里面无法渲染

大神们有没有什么方法可以解决这个问题 

代码大致是这样的  https://github.com/luyiqin123456/vuetest.git

笨蛋→说你呢的主页 笨蛋→说你呢 | 初学一级 | 园豆:126
提问于:2017-05-09 10:22
< >
分享
所有回答(2)
0

es6的方法在哪里

silianpan | 园豆:571 (小虾三级) | 2017-05-09 16:29

component:resolve => void(require(['@/components/pageA'], resolve))

这个不是么?

我是刚接触的小白不是很懂

支持(0) 反对(0) 笨蛋→说你呢 | 园豆:126 (初学一级) | 2017-05-09 16:33

@笨蛋→说你呢: 这个是es6方法,都是好像是要去掉void把

支持(0) 反对(0) silianpan | 园豆:571 (小虾三级) | 2017-05-10 16:33

@silianpan: 去掉void 还是没有用   我把代码贴上去了 可以看下大致的情况

支持(0) 反对(0) 笨蛋→说你呢 | 园豆:126 (初学一级) | 2017-05-11 13:47
0

有babel,不会的。是不是开发模式下?

Zigzag | 园豆:70 (初学一级) | 2017-05-09 17:11

build之后还是有这个问题 

component:resolve => void(require(['@/components/pageA'], resolve))这样写不行

先import pageA from '@/components/pageA'
然后component:pageA  

这样就是可以的 

好像是Promise的问题  但是不知道怎么改~~~ 

支持(0) 反对(0) 笨蛋→说你呢 | 园豆:126 (初学一级) | 2017-05-09 18:06
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册