首页新闻找找看学习计划

rpm命令如何强制安装低版本的安装包

0
悬赏园豆:50 [已解决问题] 解决于 2017-05-23 11:32

比如,在用rpm命令安装gitlab 9.2之后想安装低版本的gitlab 9.1.4

rpm -Uvh gitlab-ce-9.1.4-ce.0.el6.x86_64.rpm
Preparing...                ########################################### [100%]
	package gitlab-ce-9.2.0-ce.0.el6.x86_64 (which is newer than gitlab-ce-9.1.4-ce.0.el6.x86_64) is already installed
dudu的主页 dudu | 高人七级 | 园豆:39411
提问于:2017-05-23 11:17
< >
分享
最佳答案
0

rpm -Uvh --oldpackage [filename]

收获园豆:50
MrNice | 老鸟四级 |园豆:3012 | 2017-05-23 11:31
其他回答(1)
0

原来只需要加一个 --oldpackage 参数

rpm -Uvh --oldpackage gitlab-ce-9.1.4-ce.0.el6.x86_64.rpm
dudu | 园豆:39411 (高人七级) | 2017-05-23 11:32

支持(0) 反对(0) 苦瓜能清火 | 园豆:200 (初学一级) | 2020-02-09 18:46
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册