首页新闻找找看学习计划

未能加载文件或程序集“Oracle.ManagedDataAccess”或它的某一个依赖项。

0
悬赏园豆:100 [已解决问题] 解决于 2017-06-28 13:41

问题1: 第一次使用odp.net,添加Oracle.ManagedDataAccess.dll 时出现图下问题. 

问题2: 顺便问下 odp.net对Oracle版本有限制吗,支持9i及其它版本吗

 

 

幽默访客的主页 幽默访客 | 初学一级 | 园豆:87
提问于:2017-06-23 15:21
< >
分享
最佳答案
0

 最后原因是项目net framework版本太低,
Oracle.ManagedDataAccess.dll环境要4及4以上

幽默访客 | 初学一级 |园豆:87 | 2017-06-23 16:05
其他回答(3)
-2

缺少DLL引用,Oracle.ManagedDataAccess.dll

收获园豆:20
lionxin | 园豆:17 (初学一级) | 2017-06-23 15:59

谢谢这个问题刚解决了,这个引用了的. 最后原因是项目net framework版本太低,Oracle.ManagedDataAccess.dll环境要4及4以上

支持(0) 反对(0) 幽默访客 | 园豆:87 (初学一级) | 2017-06-23 16:04

@幽默访客: 学习了,哈哈。

支持(0) 反对(0) lionxin | 园豆:17 (初学一级) | 2017-06-23 21:51
1

Oracle.ManagedDataAccess支持10.2.0.5及以上。

Oracle.DataAccess.Client,低版本支持9,最近的版本不支持。说的这么模糊,是因为我也记不清楚哪个版本开始不支持9i了。。。但最近的版本肯定不再支持

收获园豆:60
c99 | 园豆:1832 (小虾三级) | 2017-06-23 16:26
0

调整 IIS Express 版本,Tools -> Options -> 搜索IIS -> Web Projects -> Use the 64 bit version of IIS ...

收获园豆:20
Soar、毅 | 园豆:99 (初学一级) | 2017-06-27 19:04
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册