首页 新闻 搜索 专区 学院

ionic如何降低版本,现在是3.5版本,我想降到2版本去

0
[已解决问题] 解决于 2017-07-20 10:16

我创建的项目的时候出现这个提示,是因为版本太高的原因吗?该如何降低版本呢

微微一笑回眸一生的主页 微微一笑回眸一生 | 初学一级 | 园豆:2
提问于:2017-07-19 16:05
< >
分享
最佳答案
0
npm uninstall -g ionic 
npm cache clean 
npm install -g ionic@2
奖励园豆:5
与阳光握手言和 | 菜鸟二级 |园豆:373 | 2017-07-19 17:05

这样弄完以后怎么办啊,我试着按教程上写的继续写,还是会报错

微微一笑回眸一生 | 园豆:2 (初学一级) | 2017-07-19 17:05

还会报这个错误

微微一笑回眸一生 | 园豆:2 (初学一级) | 2017-07-19 17:09

求大神帮我下,我网上查的时候,好像没有什么实质性的解决方案

微微一笑回眸一生 | 园豆:2 (初学一级) | 2017-07-19 17:11

@微微一笑回眸一生: 我也是菜鸟。><  只能帮你参谋参谋

C:\Users\Administrator在这个里面找到.cordova文件夹,删除它,再重新添加平台

与阳光握手言和 | 园豆:373 (菜鸟二级) | 2017-07-19 17:26

@与阳光握手言和: 再重新这样吗

微微一笑回眸一生 | 园豆:2 (初学一级) | 2017-07-19 17:28

@与阳光握手言和: 我刚按原来那个试了下还是原来的错误

微微一笑回眸一生 | 园豆:2 (初学一级) | 2017-07-19 17:32

确实是版本的问题,你可以多试几个版本,看一下:npm install ionic@+版本号

与阳光握手言和 | 园豆:373 (菜鸟二级) | 2017-07-20 10:15

@与阳光握手言和: ok,谢谢啦嘻嘻

微微一笑回眸一生 | 园豆:2 (初学一级) | 2017-07-20 10:16

@微微一笑回眸一生: 我也是就做过一次cordova项目,还是去年做的,会的也很少,现在好多东西都更新版本了,那么可能就会导致很多新问题,我这面用的还是以前的旧版本,目前还没出现什么问题,你可以参考一下,也可以安装我这几个版本的看下是否可行

与阳光握手言和 | 园豆:373 (菜鸟二级) | 2017-07-20 10:19

@与阳光握手言和: 好的,万分感谢大神

微微一笑回眸一生 | 园豆:2 (初学一级) | 2017-07-20 10:19

@微微一笑回眸一生: 不客气,我是菜鸟,不是大神

与阳光握手言和 | 园豆:373 (菜鸟二级) | 2017-07-20 10:21

@与阳光握手言和: 嘻嘻,刚刚我看了下我的好像每个版本都比你的高

微微一笑回眸一生 | 园豆:2 (初学一级) | 2017-07-20 10:22

@微微一笑回眸一生: 我这是去年的,现在版本肯定要高

与阳光握手言和 | 园豆:373 (菜鸟二级) | 2017-07-20 11:08
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册