首页 新闻 搜索 专区 学院

为什么的自己安装的tomcat始终是启动不了 ,为社么,难道 配置出错,,换了一个Windows10就安装什么都有毛病

0
[已解决问题] 解决于 2017-08-03 15:20

sd为什么,为什么为社 ss么,这是为社么呀。。没有有人呀

海染蓝了天LE的主页 海染蓝了天LE | 初学一级 | 园豆:26
提问于:2017-08-03 10:38
< >
分享
最佳答案
0

重装换个端口试试,比如8090

奖励园豆:5
王高啊 | 初学一级 |园豆:189 | 2017-08-03 11:02

就无法开启,,应该不是端口的问提吧

 

海染蓝了天LE | 园豆:26 (初学一级) | 2017-08-03 11:06

我把所有的端口都还了还是不行

海染蓝了天LE | 园豆:26 (初学一级) | 2017-08-03 11:16

应该不用配置吧,,因为他能自动找到jre

海染蓝了天LE | 园豆:26 (初学一级) | 2017-08-03 11:16
其他回答(3)
0

检查java环境变量和CATALINA_HOME,具体参考:

http://jingyan.baidu.com/article/870c6fc33e62bcb03fe4be90.html

ycyzharry | 园豆:22248 (高人七级) | 2017-08-03 10:46
0

报什么错呀,把错误信息贴上来,让大叔看到你这样的问问题的,肯定要出言讥讽了。

会长 | 园豆:9622 (大侠五级) | 2017-08-03 11:41

打开页面是这样的?点开tomcatw 是这样的

支持(0) 反对(0) 海染蓝了天LE | 园豆:26 (初学一级) | 2017-08-03 11:45

@海染蓝了天LE: 提示打不开这个服务,那就是这个服务没有正确安装了,看看windows日志里能发现什么。你确定已经安装了这个windows服务了吗

支持(0) 反对(0) 会长 | 园豆:9622 (大侠五级) | 2017-08-03 11:49

@会长: Windows 服务刚刚看了一下是打开的呀

支持(0) 反对(0) 海染蓝了天LE | 园豆:26 (初学一级) | 2017-08-03 12:03

@海染蓝了天LE: 你说的"打开的“是什么意思。tomcat这服务已经正常安装了,只是启动不起来的?是不是这样。如果是这样。建议你去tomcat官网看文档,应该bin目录或者什么目录下有个安装windows服务的命令,在cmd下执行一下这个命令看报什么错

支持(0) 反对(0) 会长 | 园豆:9622 (大侠五级) | 2017-08-03 14:20
0

用管理员权限打开,

并检查java环境是否配置好, java -version , javac 是否正常

苍枫露雨 | 园豆:1027 (小虾三级) | 2017-08-03 13:28

java环境没有错,,Java ,javac ,java -version 都能出来

支持(0) 反对(0) 海染蓝了天LE | 园豆:26 (初学一级) | 2017-08-03 14:03

@海染蓝了天LE: 

那用管理员权限呢,也打不开吗?

支持(0) 反对(0) 苍枫露雨 | 园豆:1027 (小虾三级) | 2017-08-03 14:14

@苍枫露雨: 刚刚换了一个8.0的版本就可以了,,应该时版本问题吧

支持(0) 反对(0) 海染蓝了天LE | 园豆:26 (初学一级) | 2017-08-03 14:26
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册