首页新闻招聘找找看知识库

样式首次加载问题

0
悬赏园豆:40 [已关闭问题]

为什么我的CSS样式第一次加载的时候不会运行,刷新过后才会出来呢,求大神解答

LRyy的主页 LRyy | 初学一级 | 园豆:154
提问于:2017-09-13 17:26
< >
分享
所有回答(4)
0

使用调试工具,

例如使用google浏览器,按F12打开开发者工具,切换到network选项卡。

然后刷新页面看看CSS样式是否有成功下载,或者有其他什么错误。

写代码的小2B | 园豆:4277 (老鸟四级) | 2017-09-13 18:21

没有错误啊

支持(0) 反对(0) LRyy | 园豆:154 (初学一级) | 2017-09-14 08:58
0

这种问题还是要上代码

ycyzharry | 园豆:6502 (大侠五级) | 2017-09-14 08:34

????

支持(0) 反对(0) LRyy | 园豆:154 (初学一级) | 2017-09-14 08:58

我的没有开通博客所以没有办法上传图片,可以加一下扣扣吗,谢谢你

支持(0) 反对(0) LRyy | 园豆:154 (初学一级) | 2017-09-14 17:01
0

有可能是浏览器缓存,你刷新第一次效果能出来吗,还是必须要刷新两次样式才出来

小西子 | 园豆:170 (初学一级) | 2017-09-14 16:12

刷新一次就可以出来

支持(0) 反对(0) LRyy | 园豆:154 (初学一级) | 2017-09-14 16:30

@LRyy: 那你的意思是,你打开网页必须要刷新一次样式才能出来吗

支持(0) 反对(0) 小西子 | 园豆:170 (初学一级) | 2017-09-14 16:33

清楚缓存也不行

支持(0) 反对(0) LRyy | 园豆:154 (初学一级) | 2017-09-14 16:34

@LRyy: 试过ctrl+F5了吗

支持(0) 反对(0) 小西子 | 园豆:170 (初学一级) | 2017-09-14 16:38

@小西子: 试了,也不行

支持(0) 反对(0) LRyy | 园豆:154 (初学一级) | 2017-09-14 16:44

@小西子: 是在页面跳转的时候不行

支持(0) 反对(0) LRyy | 园豆:154 (初学一级) | 2017-09-14 16:47

@小西子: 刚才试了,单个运行的时候可以出来,不过两个页面之间跳转的时候不行了

支持(0) 反对(0) LRyy | 园豆:154 (初学一级) | 2017-09-14 16:48

@LRyy: 你把那个css文件放在页面的哪个位置

支持(0) 反对(0) 小西子 | 园豆:170 (初学一级) | 2017-09-14 16:50

@小西子: 原来放在head中不行,之后放在body中还是不行

支持(0) 反对(0) LRyy | 园豆:154 (初学一级) | 2017-09-14 16:52

@LRyy: 那你现在放在哪个位置引入的,是放在js文件前面的吗,方便的话,可以截屏看一下吗

支持(0) 反对(0) 小西子 | 园豆:170 (初学一级) | 2017-09-14 16:53

@小西子: 加一下扣扣吧,我的没有博客,没办法上传图片

支持(0) 反对(0) LRyy | 园豆:154 (初学一级) | 2017-09-14 16:55

@LRyy: 嗯嗯,1374667972

支持(0) 反对(0) 小西子 | 园豆:170 (初学一级) | 2017-09-14 16:56
0

是你改过样式后,第一次不能刷新出来吗?可能是缓存问题,可以给css加个随机数xxx.css?v=版本号

原来、我还阳光 | 园豆:202 (菜鸟二级) | 2017-09-14 16:31
   您需要登录以后才能回答,未注册用户请先注册