首页新闻找找看学习计划

在ubuntu 16.04上安装.net core sdk 2.0.2失败

0
悬赏园豆:20 [已解决问题] 解决于 2017-11-03 11:52

安装所使用的命令

curl https://packages.microsoft.com/keys/microsoft.asc | gpg --dearmor > microsoft.gpg
sudo mv microsoft.gpg /etc/apt/trusted.gpg.d/microsoft.gpg
sudo sh -c 'echo "deb [arch=amd64] https://packages.microsoft.com/repos/microsoft-ubuntu-trusty-prod trusty main" > /etc/apt/sources.list.d/dotnetdev.list'
sudo apt-get update
sudo apt-get install dotnet-sdk-2.0.2

出现的错误如下

The following packages have unmet dependencies:
 dotnet-sdk-2.0.2 : Depends: dotnet-runtime-2.0.0 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
dudu的主页 dudu | 高人七级 | 园豆:41034
提问于:2017-11-03 11:38
< >
分享
最佳答案
0

搞错安装源了,Ubuntu 16.04 应该用这个

sudo sh -c 'echo "deb [arch=amd64] https://packages.microsoft.com/repos/microsoft-ubuntu-xenial-prod xenial main" > /etc/apt/sources.list.d/dotnetdev.list'

14.04 是 microsoft-ubuntu-trusty-prod trusty ,16.04 是 microsoft-ubuntu-xenial-prod xenial

dudu | 高人七级 |园豆:41034 | 2017-11-03 11:51
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册