首页 新闻 搜索 专区 学院

asp.net core 2.0项目引用程序集问题

0
悬赏园豆:20 [已关闭问题] 关闭于 2017-11-05 19:47

asp.net core 项目有三种引用第三方程序集的方式

1、nuget 引用

2、dll 程序集引用

3、项目引用

发现dll程序集引用 会导致运行失败,这是什么原因呢?

 

 

运行报错

 

这样就能运行正常

 

 

 

 

.net core控制台程序也做了测试 都正常

八口大箱子的主页 八口大箱子 | 初学一级 | 园豆:26
提问于:2017-11-03 19:38
< >
分享
所有回答(2)
0

把 ClassLibrary1.dll 复制另外的位置,然后通过这个位置引用试试

dudu | 园豆:37565 (高人七级) | 2017-11-03 20:22

试过了,放其他位置,再引用这个dll  运行都报这个错误

支持(0) 反对(0) 八口大箱子 | 园豆:26 (初学一级) | 2017-11-03 20:25

https://github.com/dotnet/core-setup/issues/2981

支持(0) 反对(0) 八口大箱子 | 园豆:26 (初学一级) | 2017-11-03 20:28

@sylla: 你用的是 .net core sdk 2.0.2 ?

支持(0) 反对(0) dudu | 园豆:37565 (高人七级) | 2017-11-03 20:34

@dudu: 没有  用的是2.0

我也是网上找不到解决方案,在stackoverflow上面找到这个

https://stackoverflow.com/questions/46279561/asp-net-core-2-cannot-find-compilation-library-location-for-package-projectname

才知道是2.0确实存在这个问题

支持(0) 反对(0) 八口大箱子 | 园豆:26 (初学一级) | 2017-11-03 20:41

@sylla: 我刚试了一下 .net core sdk 2.0.2 也有这个问题,只能等 .net core 2.0.1 发布了

支持(0) 反对(0) dudu | 园豆:37565 (高人七级) | 2017-11-03 20:48

@dudu: 谢谢!

支持(0) 反对(0) 八口大箱子 | 园豆:26 (初学一级) | 2017-11-03 20:56
0

额滴个神哪,微软咋这么不靠谱,都 2.0.2 了还出这么低级的错误,我还是等着发布 FineUI 的 Core 2.0 版本呢,这不能引用第三方程序集可咋搞....

三生石上(FineUI控件) | 园豆:224 (菜鸟二级) | 2017-11-15 13:37

.Net Core 2.0.3已经支持了:http://www.cnblogs.com/sanshi/p/7841104.html

支持(0) 反对(0) 三生石上(FineUI控件) | 园豆:224 (菜鸟二级) | 2017-11-16 11:22
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册