首页 新闻 赞助 找找看

.net 2.0基础上,用jQuery调用WebService,找不到WebService方法

0
[已关闭问题]

 

“/”应用程序中的服务器错误。

 

Only Web services with a [ScriptService] attribute on the class definition can be called from script.

 

说明: 执行当前 Web 请求期间,出现未处理的异常。请检查堆栈跟踪信息,以了解有关该错误以及代码中导致错误的出处的详细信息。 

 

 

 

 需要加什么属性才可以啊? 

 

 加了 [System.Web.Script.Services.ScriptService] 不好使。在3.5中都是运行正常的!

 

 高手们,帮帮忙啊。。。谢谢

Mr.Cantus的主页 Mr.Cantus | 初学一级 | 园豆:24
提问于:2009-11-10 11:29
< >
分享
其他回答(2)
0

不会吧 蛮简单的 我正好再用 代码贴上来看看

迟暮 | 园豆:2 (初学一级) | 2009-11-10 15:09
0

新建一个asp.net2.0 ajax项目或网站,把web.config生成的文件复制过来到你的项目,

注意2.0和3.5对应的GAC中的dll版本不同,运行环境也不同。

2.0升3.5可以。反之则不行。

邀月 | 园豆:25475 (高人七级) | 2009-11-10 15:36
0

嗯.向下兼容.不能向上兼容容

邢少 | 园豆:10926 (专家六级) | 2009-11-11 11:31
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册