首页新闻找找看学习计划

C# 连接redis 错误(疑似版本问题)

0
悬赏园豆:10 [已解决问题] 解决于 2018-08-23 09:56

.net framework 4.7.1 连接 redis时出错:

  “System.AggregateException”类型的未经处理的异常在 mscorlib.dll 中发生 

代码:

var connectionMultiplexer = ConnectionMultiplexer.Connect(connStr)

 

在其他版本倒是没有出现,求解决方案

Not`Anymore的主页 Not`Anymore | 菜鸟二级 | 园豆:217
提问于:2018-07-09 18:03

用的是哪个redis客户端?

dudu 1年前

@dudu: Redis server v=3.2.100 sha=00000000:0 malloc=jemalloc-3.6.0 bits=64 build=dd26f1f93c5130ee

Not`Anymore 1年前

@Not`Anymore: 我指的是C#客户端

dudu 1年前

@dudu: 我用 StackExchange.Redis 1.2.6 这个包连的

Not`Anymore 1年前
< >
分享
最佳答案
0

没有这个版本的 EF

收获园豆:10
dudu | 高人七级 |园豆:41280 | 2018-07-09 21:02

……  redis连接  跟 ef 有什么关系?

Not`Anymore | 园豆:217 (菜鸟二级) | 2018-07-10 08:55

@Not`Anymore: 你在提问中写的“entity framework 7.1 连接 redis时出错”

dudu | 园豆:41280 (高人七级) | 2018-07-10 09:25

@dudu: 已修改  写错了:) 

Not`Anymore | 园豆:217 (菜鸟二级) | 2018-07-10 11:41

@Not`Anymore: 微软发布了 .NET Framework 4.7.2,可以安装试试

dudu | 园豆:41280 (高人七级) | 2018-07-11 13:48
其他回答(1)
0

还是回到了起点 版本问题  =-= 具体问题不知

Not`Anymore | 园豆:217 (菜鸟二级) | 2018-08-01 20:23
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册