首页 新闻 赞助 找找看

vue项目运行报此错误:Unknown option '--inline'

0
[待解决问题]

不知道是不是因为运行一个 npm webpack什么什么的命令,然后与再npm run dev就出现这个问题了。有谁知道这是怎么引起的,应该怎么解决吗?
package.json文件的代码:

"scripts": {
"dev": "webpack-dev-server --inline --progress --config build/webpack.dev.conf.js",
"start": "npm run dev",
"build": "node build/build.js"
}

echomay的主页 echomay | 菜鸟二级 | 园豆:217
提问于:2022-03-07 22:23
< >
分享
所有回答(3)
0

去掉 '--inline' 参数,详见 https://stackoverflow.com/a/70532911

dudu | 园豆:31377 (高人七级) | 2022-03-07 23:09

试过这个方法,但是也不可以。去掉后报config……什么什么的错

支持(0) 反对(0) echomay | 园豆:217 (菜鸟二级) | 2022-03-07 23:17
0

直接把 --inline去掉跑不行吗?

人间春风意 | 园豆:2335 (老鸟四级) | 2022-03-08 10:56

去掉之后报了这样的错误

支持(0) 反对(0) echomay | 园豆:217 (菜鸟二级) | 2022-03-08 18:13

@echomay:

"scripts": {
"serve": "vue-cli-service serve",
"build": "vue-cli-service build",
"lint": "vue-cli-service lint"
},

这样试试可行不?

支持(0) 反对(0) 人间春风意 | 园豆:2335 (老鸟四级) | 2022-03-08 19:32

@人间春风意: 你这个启动命令必须配 vue.config.js 文件.

支持(0) 反对(0) just coding | 园豆:159 (初学一级) | 2022-03-09 16:27
支持(0) 反对(0) 人间春风意 | 园豆:2335 (老鸟四级) | 2022-03-09 17:43
0

webpack-dev-server 版本问题. 建议换低版本试试.

just coding | 园豆:159 (初学一级) | 2022-03-09 16:28
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册