首页 新闻 会员 周边

前端vue报错

0
悬赏园豆:30 [已解决问题] 解决于 2023-04-09 18:42


报错是这样的,按照报错提示安装包还是不行,求大佬解答

陌离~的主页 陌离~ | 初学一级 | 园豆:61
提问于:2023-04-06 22:29

你把报错复制成文本贴上来

Technologyforgood 1年前
< >
分享
最佳答案
0

虽然Webpack很优秀,但是配置过于复杂,各种loader稍有不慎就错误,新手很难从里面爬出来。(见过太多卡Webpack配置的同学了....)
别的项目不敢打包票,但是Vue项目的话,无脑用Vite就完事了,谁用谁知道,早用早享受。
关于提问中的错误,给出以下几个思路:
1、 检查nodejs版本
2、检查报错的loader版本和加载顺序(sass那个loader在webpack中真的一言难尽)
3、用Vite构建Vue项目

收获园豆:20
顾星河 | 大侠五级 |园豆:7242 | 2023-04-07 15:26
其他回答(2)
0

node 用的什么版本,兄弟, 如果是16.19 ,建议降到16.18
我现在也是用的16.19 发现了跟你差不多的问题
heqigongzi@192 ~ % npm -v
6.14.18
heqigongzi@192 ~ % node -v
v16.19.0
heqigongzi@192 ~ %

收获园豆:10
男人要爽 | 园豆:6 (初学一级) | 2023-04-06 23:12

16.7几

支持(0) 反对(0) 陌离~ | 园豆:61 (初学一级) | 2023-04-07 08:17
0

16.15没问题

echo_lovely | 园豆:1352 (小虾三级) | 2023-04-07 08:55
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册