首页 新闻 会员 周边

vue脚手架安装问题

0
[已解决问题] 解决于 2023-08-30 23:22

安装命令npm install -g @vue/cli
回车后:一直这样:
然后就报错

网上许多方法都试过了,还是没用,使用淘宝镜像也没用

五号位的主页 五号位 | 初学一级 | 园豆:173
提问于:2023-05-24 13:28
< >
分享
最佳答案
0

vue cli现在处于维护阶段,官方的脚手架现在用的是create-vue,这一指令将会安装并执行 create-vue:
npm init vue@latest
另,这个脚手架构建的项目是Vue3,需要具备一定基础。

奖励园豆:5
顾星河 | 大侠五级 |园豆:7238 | 2023-05-24 14:16

还是不行,

五号位 | 园豆:173 (初学一级) | 2023-05-24 15:18

@五号位: 你这镜像源看起来好像有点问题,试着修改一下镜像源为淘宝的:
npm config set registry http://registry.npm.taobao.org/
同时,检查一下nodejs的版本,建议保持在18及以上。
node -v 可以查看nodejs版本
npm get registry 可以查看当前镜像源

顾星河 | 园豆:7238 (大侠五级) | 2023-05-24 17:14

@默卿:
还是不行,有什么其他方法吗

五号位 | 园豆:173 (初学一级) | 2023-05-24 19:38
其他回答(1)
0

改成自己手机热点试下,公司网络可能有问题- -

丶24k纯帅 | 园豆:415 (菜鸟二级) | 2023-05-30 16:52
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册