首页 新闻 搜索 专区 学院

ant 1.8 不兼容1.7吗?

0
悬赏园豆:10 [已解决问题] 解决于 2010-08-18 08:35

BUILD FAILED
D:\jboss-seam-2.2.0.GA\build.xml:9: You are using Apache Ant version 1.8.1 compi
led on April 30 2010. You must use Ant 1.7.0 to build Seam. Ant 1.7.1 has known
bugs.

站在十字路口的人的主页 站在十字路口的人 | 初学一级 | 园豆:190
提问于:2010-08-12 16:17
< >
分享
最佳答案
0

要在这里修改:

<javac destdir="${product.classes}" nowarn="on" debug="${java.debug}">
<classpath>
<fileset dir="../lib">
<patternset refid="compile.libs"/>
</fileset>
</classpath>
<src path="src"/>

</javac>

改为:

<javac source="1.7" destdir="${product.classes}" nowarn="on" debug="${java.debug}">
<classpath>
<fileset dir="../lib">
<patternset refid="compile.libs"/>
</fileset>
</classpath>
<src path="src"/>

</javac>

收获园豆:10
jowo | 老鸟四级 |园豆:2834 | 2010-08-12 17:25
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册