首页新闻找找看学习计划

没有装VS2005,用2010直接打不开VS2005编写的项目嘛?

0
悬赏园豆:5 [已解决问题] 解决于 2012-12-22 17:43

今天装了VS2010用, 没有装VS2005,打开以前用VS2005编写的一个程序时,发出如图的错误提示"……所需的应用程序未安装,确认已安装项目项型(.csproj)的应用程序"!!不会那么纠结吧!!VS2003可以直接打开VS2003的文件只要点转换就行了!!VS2010落后了?!!

急求解答…………………………………………………………………………………………………

问题补充:

如果不是VS2010本身设计的问题就是安装出了问题了, 我想是求得解决这个问题的办法, 有没有那一位高手,遇见过这种情况的!!我是重装了系了,然后先装SQL2005,然后再装VS2010旗舰版!!

梦愿的主页 梦愿 | 初学一级 | 园豆:165
提问于:2012-12-22 12:35
< >
分享
最佳答案
0

可以打开,不过要转换成vs10版本的。转换的时候一般会有一个向导。

 

你把vs05的解决方案拖到vs10的起始页

收获园豆:5
仰望繁星的猪 | 菜鸟二级 |园豆:286 | 2012-12-22 16:15

这种方式确实可行!!!神马情况,直接点解决方案不行, 这样子就行了!!!

梦愿 | 园豆:165 (初学一级) | 2012-12-22 17:44

@梦愿: 直接打开的时候,默认是已vs05的方式打开,所以会提示没有安装vs05.

拖动到vs2010里面就是以vs2010版本打开。

如果vs05写的程序,本机只安装了vs08,双击解决方案,可以直接打开vs08进行版本转换。

vs2010没有提示,必须手动

仰望繁星的猪 | 园豆:286 (菜鸟二级) | 2012-12-22 21:47
其他回答(4)
0

vs2010能打开的。

悟行 | 园豆:12238 (专家六级) | 2012-12-22 12:43
0

完全可以打开

chenping2008 | 园豆:9836 (大侠五级) | 2012-12-22 13:23
0

高版本可以打开低版本,以前的程序有错吗?

光头之雨男 | 园豆:196 (初学一级) | 2012-12-22 13:39
0

应该是你电脑上没有安装那个版本的.Net的问题吧,不要直接打开,右键点【编辑】,vs会以文本的格式打开项目的csproj配置文件,修改对应的net版本试试.

实在不行用sharpdevelop打开转换下

RyanCheng | 园豆:474 (菜鸟二级) | 2012-12-22 13:57
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册