描述
输入一个字符串str和一个子串s,统计str中子串s的个数。
输入
输入数据有2行,第一行为str,第二行为s
输出
输出子串的个数
样例输入
样例输出
string str;
string s;
int n = 0;
if (str.Contains("s"))
{
n++;
}
#include <iostream>
#include <string>
using namespace std;
int main()
{ string str;
string s;
while(cin>>str)
{ cin>>s;
int n = 0;
if (str.Contains("s"))
{
n++;
}
cout<<n<<endl;
}
return 0;
}
反复的调用 strstr 就行了。好像没啥好解释的。