首页 新闻 搜索 专区 学院

MVC网站发布到.net4.0虚拟空间报错_100¥

0
悬赏园豆:60 [已解决问题] 解决于 2014-07-17 09:54

发布到本地IIS没有问题,发到空间上居然报错不能加载NuGet.Core.  我没有这个版本的NuGet.Core.dll  放了高版本进去也不对。照理说这个时候和NuGet已经没有关系了吧。

不知道大家有没有遇到过,搞了好几天,没发布成功,求解决,悬赏100¥。可以冲话费也可以打支付宝~ 

问题补充:

这也有同样的问题 http://stackoverflow.com/questions/18228785/error-in-azure-could-not-load-file-or-assembly-nuget-core

但我Nuget 已经是最新的

stoneniqiu的主页 stoneniqiu | 初学一级 | 园豆:80
提问于:2014-07-15 20:43
< >
分享
最佳答案
0

 I think a have the same problem, but a reslove it,I forgot the detail.you shoud restall .net framework or asp.net,because my work computer no chinese,so I have to write English,You can add my qq:330497448,I try to help You.

收获园豆:40
who teach me | 菜鸟二级 |园豆:242 | 2014-07-16 18:37
其他回答(5)
0

我发布过很多mvc的web程序,遇到各种问题,你这个印象没有遇过,不过应该不难解决啦,但是需要调试,不知道怎么帮你呢

收获园豆:20
LYHISTORY.COM | 园豆:222 (菜鸟二级) | 2014-07-15 21:38

~~ 你加我QQ吧,我把工程给你 76617768

支持(0) 反对(0) stoneniqiu | 园豆:80 (初学一级) | 2014-07-15 22:24
0

nuget这个类库是你项目必须的吗?如果不是必须的,删除引用,然后重新编译一下。

如果是虚拟主机的话,建议清理一下iis应用程序池

James.Ying | 园豆:1472 (小虾三级) | 2014-07-15 22:00

引用里面就没有引用Nuget,不清楚怎么造成的

支持(0) 反对(0) stoneniqiu | 园豆:80 (初学一级) | 2014-07-15 22:22

@stoneniqiu: 在你的 Web.config 中找找 Nuget 的引用

支持(0) 反对(0) Launcher | 园豆:45045 (高人七级) | 2014-07-16 08:44

@stoneniqiu: 看下是不是把package文件夹也传上去了

支持(0) 反对(0) James.Ying | 园豆:1472 (小虾三级) | 2014-07-16 09:30

@James.Ying: ~~ 没传,dll都在bin目录下。

支持(0) 反对(0) stoneniqiu | 园豆:80 (初学一级) | 2014-07-16 10:06
0

虚拟主机管理平台有设置.netframework版本和MVC配置的信息吧?你看下这块设置,有没有跟你的应用不符合的?

比如你的应用是.netframework4.0,主机设置的却是2.0

Alex_QY1987 | 园豆:1888 (小虾三级) | 2014-07-16 10:02

是4.0的, 主机是2.0的话 只会显示目录

支持(0) 反对(0) stoneniqiu | 园豆:80 (初学一级) | 2014-07-16 10:06
0

NuGet.Core.dll  发我吧 1026771999
另外把你的WebConfig这部分的配载也给我

丫的 | 园豆:1575 (小虾三级) | 2014-07-16 10:34
1

你可以换个空间或装个干净的虚机试一下,先确认一下试环境还是发布的问题

陈齐 | 园豆:311 (菜鸟二级) | 2014-07-17 09:42

谢谢,问题已经找到,是数据库的问题,我用的compact,服务器上面不支持,可能也是我配置不对

 

支持(0) 反对(0) stoneniqiu | 园豆:80 (初学一级) | 2014-07-17 09:54
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册