首页 新闻 搜索 专区 学院

asp.net vnext dll版本冲突

0
悬赏园豆:50 [已解决问题] 解决于 2015-04-05 17:32

如图,分别安装两个包,由于这两个包依赖的版本不同,导致安装失败,请问怎么解决。

老牛在路上的主页 老牛在路上 | 初学一级 | 园豆:11
提问于:2015-04-04 19:42
< >
分享
最佳答案
0

解决方法。http://www.cnblogs.com/liqiao/p/4394393.html

老牛在路上 | 初学一级 |园豆:11 | 2015-04-05 17:30
其他回答(1)
0

它说的是大于这个版本,你只要用写的就没问题了

收获园豆:50
刘宏玺 | 园豆:14020 (专家六级) | 2015-04-05 00:28

因为signalR.selfHost和owin.cors都是依赖microsoft.owin的,但是一个依赖的是3.0版本,另一个是2.1版本,但我在一个项目里没办法同时引用两个同名的包,所以报错。

支持(0) 反对(0) 老牛在路上 | 园豆:11 (初学一级) | 2015-04-05 17:02

@老牛在路上:自己解决了。

支持(0) 反对(0) 老牛在路上 | 园豆:11 (初学一级) | 2015-04-05 17:30
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册