首页新闻找找看学习计划

SQL SERVER2008还原数据库提示版本不兼容怎么办?

0
悬赏园豆:50 [已解决问题] 解决于 2016-01-21 20:14

只有bak文件,没有sql文件。我的数据库可以升级,如果升级,怎么升?

Juniors的主页 Juniors | 初学一级 | 园豆:24
提问于:2015-05-30 07:54
< >
分享
最佳答案
0

只能在R2先还原,然后利用导出sql脚本的方式,才能在低版本上还原。建议直接升级到R2.

收获园豆:15
幻天芒 | 高人七级 |园豆:36522 | 2015-05-30 09:10
其他回答(4)
0

10.50.1600是SQL Server 2008 R2,你安装R2然后进行还原。

收获园豆:10
dudu | 园豆:39087 (高人七级) | 2015-05-30 08:57
0

好吧,楼上都说了,不过下次你碰到这种吓人的对话框呢,

花点时间把“运行版本10.50.1600”复制到浏览器里面搜索一下,答案自然就有了。

楼上这两家伙肯定就是这么做的,现炒现卖。

收获园豆:10
爱编程的大叔 | 园豆:29862 (高人七级) | 2015-05-30 09:27

谢谢

支持(0) 反对(0) Juniors | 园豆:24 (初学一级) | 2015-05-31 12:28
0

来看楼上仨

收获园豆:5
黑峰 | 园豆:544 (小虾三级) | 2015-05-30 11:23
0

当初我也遇到过这个问题,除了sql脚本,你还可以试一试附加数据库,我这样解决过问题,但是不保证各个不同版本的sql都行。

收获园豆:10
泰德 | 园豆:10 (初学一级) | 2015-05-30 15:30
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册