首页新闻找找看学习计划

python做一个工具,需要用到自带的版本,但是环境变量的不一样,import的路径还是本机装的

0
悬赏园豆:20 [待解决问题]

我要用自带的python执行我写的脚本,但是操作系统装的是python2.4的比较古老。

我在脚本里面import socket但是这个是指向2.4版本的,然后很多接口都是不通用的。我改如何修改?

ferraborghini的主页 ferraborghini | 初学一级 | 园豆:40
提问于:2015-12-22 22:05
< >
分享
所有回答(2)
1

python会去环境变量PYTHONPATH指定的路径中找模块,你可以在代码中修改sys.path这个变量,改变python寻找的路径

Uteki | 园豆:573 (小虾三级) | 2016-02-05 14:25
0

把你的程序打包发布。

codegay | 园豆:1644 (小虾三级) | 2016-03-09 02:06
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册