首页 新闻 搜索 专区 学院

大侠,请留步!android studio 版本问题,冲突 ,sdk25是不是必须jdk1.8呀?现在就是1.8

0
悬赏园豆:15 [已解决问题] 解决于 2017-02-16 10:30

android studio 版本问题,冲突  ,sdk25是不是必须jdk1.8呀?现在就是1.8

问题补充:

这个是问题导火索。如下图

贵^_^公子的主页 贵^_^公子 | 初学一级 | 园豆:112
提问于:2017-01-05 10:38
< >
分享
最佳答案
0

sdk和jdk没有任何关系,要么是你app文件依赖的包gradle要求不是25,而你依赖的是25,或者是你引入的library文件中的gradle中的compile不是25,把所有gradle看看

收获园豆:10
程序员大亨 | 菜鸟二级 |园豆:276 | 2017-01-17 09:38

很感谢,但是网上的说法试遍了也无法解决。版本都是一致的,这个错误不会导致打包失败,但是会导致警告。主要是影响了terminal的调试

贵^_^公子 | 园豆:112 (初学一级) | 2017-01-17 10:28
其他回答(1)
0

第一: 你在CMD下输入java -version 和 javac -version 看是不是都是1.8 ? 

第二: 在你的AS中Terminal中也这样输入看是否都是1.8

第三: 打开项目结构看一下SDK版本的问题

收获园豆:5
zeroonec | 园豆:59 (初学一级) | 2017-01-05 15:24

没错的。

支持(0) 反对(0) 贵^_^公子 | 园豆:112 (初学一级) | 2017-01-09 13:24
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册