首页新闻找找看学习计划

这个java项目怎么编译成jar包?

0
悬赏园豆:5 [已解决问题] 解决于 2017-07-07 15:28

https://github.com/square/okhttp

如题,要求使用eclipse

逐梦者66的主页 逐梦者66 | 初学一级 | 园豆:106
提问于:2017-05-17 11:02
< >
分享
最佳答案
0

maven项目直接maven install就可以了

收获园豆:5
AnonymouL | 小虾三级 |园豆:1769 | 2017-05-17 11:55

[INFO]
[INFO] --- maven-enforcer-plugin:1.0:enforce (enforce-maven) @ okhttp ---
[WARNING] The POM for org.apache.maven:maven-artifact:jar:2.0.9 is missing, no dependency information available
[WARNING] The POM for org.apache.maven:maven-plugin-api:jar:2.0.9 is missing, no dependency information available
[WARNING] The POM for org.apache.maven:maven-project:jar:2.0.9 is missing, no dependency information available
[WARNING] The POM for org.apache.maven:maven-core:jar:2.0.9 is missing, no dependency information available
[WARNING] The POM for commons-lang:commons-lang:jar:2.3 is missing, no dependency information available
[WARNING] The POM for org.apache.maven.enforcer:enforcer-api:jar:1.0 is missing, no dependency information available
[WARNING] The POM for org.apache.maven.enforcer:enforcer-rules:jar:1.0 is missing, no dependency information available
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE

 

能告诉我这个错误怎么处理吗?

逐梦者66 | 园豆:106 (初学一级) | 2017-05-22 10:57

@春色园: 本地下载maven了么

AnonymouL | 园豆:1769 (小虾三级) | 2017-05-22 13:51

@AnonymouL: 有啊,要不然这个错误怎么报出来的呢?

逐梦者66 | 园豆:106 (初学一级) | 2017-05-22 16:03

@春色园: 看下你配置的仓库能用么?可以用的话看下仓库里有没这些包

AnonymouL | 园豆:1769 (小虾三级) | 2017-06-02 17:27
其他回答(2)
0

是不是配置的原因 仓库没有设置好!环境变量的什么也配置了吗

吉吉的城 | 园豆:551 (小虾三级) | 2017-05-22 23:46
0

菜单列表(File)-export-java-jar,就可以了

tuwosh | 园豆:18 (初学一级) | 2017-06-20 13:49
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册