首页新闻找找看学习计划

为什么我用webstorm开发angular2的时候运行直接出现这种错误,,大神求解了?

0
悬赏园豆:15 [待解决问题]

最近刚刚学习angular2连个hello word 都打印不出来,,,哎i啊爱爱啊

问题补充:

然后在命令行中输入 ag -- help指令是这样的。,,,,

海染蓝了天LE的主页 海染蓝了天LE | 初学一级 | 园豆:26
提问于:2017-08-10 23:08
< >
分享
所有回答(3)
0

第一张图告诉检查一下NODE版本,我看了,你的版本足够高了。所以应该不是NODE版本不够,一般也不会是太高造成的。

所以问题就是出在代码中了。

第二张图的意思是找不到rxjs/symbol/observable ,所以要买你的angular-cli安装有问题,要么你没有安装rxjs依赖啥的。

其他就看不出来了。

爱编程的大叔 | 园豆:30267 (高人七级) | 2017-08-11 09:21

第一张图 我直接创建一个anguler2 的工程,什么代码都没有改,,然后就直接package.json再就start了,r如果能运行 应该会出现appwork的吧

支持(0) 反对(0) 海染蓝了天LE | 园豆:26 (初学一级) | 2017-08-11 16:50

还有会不会是安装angular cli的时候出现的问题呢?因为网上教程太多了。各有个的不同,,我的这个是node+nmp+angular cli,node 和nmp 在终端输入node -v和nmp -v 都能出现对应的版本号,但是ng-v的时候只出现三行代码,一个是angular的版本号,一个是node的版本号,在一个就是Windows的一些信息,教程太杂了

支持(0) 反对(0) 海染蓝了天LE | 园豆:26 (初学一级) | 2017-08-11 16:55
0

npm i -S @angular/compiler-cli rxjs

幻天芒 | 园豆:36594 (高人七级) | 2017-08-11 13:21
0

推荐用vscode

苏黎世宝贝 | 园豆:279 (菜鸟二级) | 2017-08-16 22:14
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册