首页新闻找找看学习计划

.net standard 2.0 下载

0
悬赏园豆:50 [已解决问题] 解决于 2017-08-31 11:44

早前在使用 vs 2017 15.3 preview时,还能下载安装 netstandard 2.0,也能在项目的目标框架里配置各种 netstandard 版本(1.0-1.6、2.0)。

 

现在我安装了VS 2017 15.3.2(15.3.3)后,发现目标框架只有 core 1.0、1.1、2.0(自行额外安装),没有了netstandard的各个版本。

 

网络上到处搜索,也找不到下载入口了,请问:

 

是不再提供单独的netstandard了吗?由core全部替代?

 

谢谢!

 

 

 

 

 

 

 

 

 

问题补充:

问题解决了。

 

我是早期的csproj文档,不知道怎么的,到了新版本(系统全新安装),目标框架里只有 .net core的选项,而没有 netstandard 的选项。

 

刚实验了,能在vs里创建netstandard项目,我手工修改csproj的内容,问题解决。

 

感谢各位。

 

 

519740105的主页 519740105 | 大侠五级 | 园豆:5810
提问于:2017-08-31 09:58
< >
分享
最佳答案
0
收获园豆:25
BUTTERAPPLE | 老鸟四级 |园豆:2918 | 2017-08-31 11:37

也有安装。

519740105 | 园豆:5810 (大侠五级) | 2017-08-31 11:41
其他回答(1)
0

.NET Standard 2.0 的下载地址:netstandard2.0.md

收获园豆:25
dudu | 园豆:41299 (高人七级) | 2017-08-31 10:05

谢谢。我找过这个页面,没有链接。

 

支持(0) 反对(0) 519740105 | 园豆:5810 (大侠五级) | 2017-08-31 11:28

@519740105: .NET Standard 2.0 是一个api规范(标准),不是一个软件

支持(0) 反对(0) dudu | 园豆:41299 (高人七级) | 2017-08-31 11:41

@dudu:
又遇到一个新的问题:

我切换到 netstandard2.0 后,显示的platform是netcore1.1,怎么能变成 netcore 2.0?

 

我已经安装了netcore 2.0 sdk:https://github.com/dotnet/core/blob/master/release-notes/download-archives/2.0.0-download.md

支持(0) 反对(0) 519740105 | 园豆:5810 (大侠五级) | 2017-08-31 12:08
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册